Problem with headlights

1945 - 196*, Willys CJ series, questions, discussions, regarding anything related to the post war jeep.®
Post Reply
32sbct
G-Sergeant First Class
G-Sergeant First Class
Posts: 76
Joined: Sun Sep 30, 2012 2:22 pm

Problem with headlights

Post by 32sbct » Fri Jul 31, 2020 2:33 pm

So, my jeep is an M38 but it has a Willys MB motor, and is 12 volt. It is wired the same as a CJ3A. I used a new CJ3A wiring harness from Walcks modified for turn signals and key start. I'm having a problem with the headlights. At some point this year they stopped working. I thought it was the bulb so I replaced the one on the drivers side and now it works but only on one setting. I'm not sure if it is low beam or high beam. The passenger side is just barely on. My jeep has a new CJ3A two position headlight switch. The first position for the marker lights works fine. The second position for the headlights sends power to the dimmer switch which is also new. I'm not sure how to troubleshoot this one. Everything is new, connections are tight and grounded. Electrical issues are a weak spot for me from a knowledge perspective. Any thoughts would be appreciated.

Rus Curtis
Sergeant Major of the Gee
Sergeant Major of the Gee
Posts: 394
Joined: Wed Apr 05, 2006 4:51 am
Location: Alabama

Re: Problem with headlights

Post by Rus Curtis » Sat Aug 01, 2020 8:35 am

You can approach this in more that one way. If you had a multimeter, you could check voltage (or continuity, i.e. ohms) before and after connections to see if there's a drop. You can also use a test light but that may not give you as much information. You can also disconnect items, i.e. dimmer switch or ignition switch (Note: this can be done with a jumper wire, when the switch being tested is detached from the body), and make direct connections to see if there's a difference.

You say connections are tight and grounded. How do you know the circuits are grounded? Just because the wire is "connected" doesn't mean it's actually completing the circuit (or actually grounded). If a connection has a good coating of filler, primer or paint (or all 3) it can act as an insulator effectively blocking electrical flow.

I had similar issues with fresh paint, new harness and new light units. I went from the beginning (battery) to the end (light) checking each wire and connection in between, i.e. switches/wire plugs, and eventually found it in the bulb socket. On my turn signal switch I ended up running a separate ground wire in the harness before I could get that to work. I had a multimeter and some jump wires with alligator clips on both ends to double up ground connections if needed for checking.

Be methodical. Do one light at a time. Suspect everything - including new components.
Rus Curtis
'54 CJ-3B
T3-C

32sbct
G-Sergeant First Class
G-Sergeant First Class
Posts: 76
Joined: Sun Sep 30, 2012 2:22 pm

Re: Problem with headlights

Post by 32sbct » Sat Aug 01, 2020 12:32 pm

Rus, thanks that is very good advice. I'll give it a try and repost what I find.

32sbct
G-Sergeant First Class
G-Sergeant First Class
Posts: 76
Joined: Sun Sep 30, 2012 2:22 pm

Re: Problem with headlights

Post by 32sbct » Sat Aug 01, 2020 2:55 pm

Problem solved. Well I went through everything step by step and I'm embarrassed to say what I found. I had wired the dimmer switch incorrectly. I had the high beam wire on the power terminal and the power wire on the high beam side of the switch. I live in Pennsylvania and you can't drive a vehicle with antique tags after dusk so I've never used the lights. Oh well that was an easy fix and a good lesson learned.

Rus Curtis
Sergeant Major of the Gee
Sergeant Major of the Gee
Posts: 394
Joined: Wed Apr 05, 2006 4:51 am
Location: Alabama

Re: Problem with headlights

Post by Rus Curtis » Sat Aug 01, 2020 5:17 pm

Excellent! Well done!
Rus Curtis
'54 CJ-3B
T3-C

Post Reply

Return to “CJ Technical Knowledge Base”

Who is online

Users browsing this forum: No registered users and 5 guests