Not able to upload any pictures

Discussion relating to the G503 photo hosting site surfacezero.com.
User avatar
Beep
Sergeant Major of the Gee
Sergeant Major of the Gee
Posts: 308
Joined: Mon Feb 02, 2004 12:24 pm
Location: South Africa

Re: Not able to upload any pictures

Post by Beep » Sat Apr 06, 2024 7:21 am

thovis wrote:
Fri Apr 05, 2024 7:49 pm
*UPDATE* There were a couple issues that I can see. 1) The host automatically added a 3mo SSL cert, which I removed as there has never been a cert on this site I believe. So only use http:// (https:// is not enabled)
2) there were over 1200+ connections from Chinese IP addresses... I started blocking them to make the count of connections down.
I tried to upload and it worked for me.

Please try again and see if you can upload.

Tom H.
Hi Tom,
I have been able to load pics but when I try and post them anywhere else they dont work. All I get is the image symbol
42MB 130700


User avatar
zepher11
G-Lieutenant General
G-Lieutenant General
Posts: 4387
Joined: Fri Aug 12, 2011 7:37 pm
Location: The Real Northern CalifornIA

Re: Not able to upload any pictures

Post by zepher11 » Sat Apr 06, 2024 4:24 pm

Same here. I looked at my previous threads on the G503, and none of my photos appear any longer from the surfacezero site. Links are all broken.

I can upload to surfacezero now which is good, but losing over ten years of posted photos is really not good. lol

Hopefully, Tom can take a look at that too.
Zeph

'42 Script GPW Restoration Thread: CLICK HERE!

'41 Dodge WC16 Restoration Thread: CLICK HERE!

User avatar
thovis
G-Colonel
G-Colonel
Posts: 1209
Joined: Fri Oct 08, 2004 9:35 am
Location: Central Coast, CA
Contact:

Re: Not able to upload any pictures

Post by thovis » Sat Apr 06, 2024 8:20 pm

Checking the IPs I blocked. I rolled back a few of them to see if they will come through... will be checking periodically as it takes a little time to propagate.

Tom H.
Restore help
http://1942GPW.com - http://1945GPW.com
http://1941MB.com - http://1945MB.com
G506 Chevrolet Cargo
G506 Chevrolet Panel

Steve Webb
G-General
G-General
Posts: 16733
Joined: Fri Jan 17, 2003 3:40 pm
Location: Fort Myers, Florida

Re: Not able to upload any pictures

Post by Steve Webb » Sun Apr 07, 2024 11:20 am

Thanks I was really puzzled had not changed anything on my computer and done same way of loading for years.
Stand for the Flag, Kneel for the Cross Psalm 55; 9-11

User avatar
thovis
G-Colonel
G-Colonel
Posts: 1209
Joined: Fri Oct 08, 2004 9:35 am
Location: Central Coast, CA
Contact:

Re: Not able to upload any pictures

Post by thovis » Mon Apr 08, 2024 6:02 pm

*update2* - Just letting the thread know I am still looking at why images don't appear on G503 and the other .za domain. I have now backed out all of my blocking IP ranges. So I believe I am back to the starting point. One good thing, is it did clear out some of the IP address connections so that uploads could occur. Rest assured, the images are still there... its just he issue at hand with the image links still trying to solve.

Tom H.
Restore help
http://1942GPW.com - http://1945GPW.com
http://1941MB.com - http://1945MB.com
G506 Chevrolet Cargo
G506 Chevrolet Panel

User avatar
zepher11
G-Lieutenant General
G-Lieutenant General
Posts: 4387
Joined: Fri Aug 12, 2011 7:37 pm
Location: The Real Northern CalifornIA

Re: Not able to upload any pictures

Post by zepher11 » Tue Apr 09, 2024 5:44 am

thovis wrote:
Mon Apr 08, 2024 6:02 pm
*update2* - Just letting the thread know I am still looking at why images don't appear on G503 and the other .za domain. I have now backed out all of my blocking IP ranges. So I believe I am back to the starting point. One good thing, is it did clear out some of the IP address connections so that uploads could occur. Rest assured, the images are still there... its just he issue at hand with the image links still trying to solve.

Tom H.
Thank you Tom.
Zeph

'42 Script GPW Restoration Thread: CLICK HERE!

'41 Dodge WC16 Restoration Thread: CLICK HERE!

User avatar
Beep
Sergeant Major of the Gee
Sergeant Major of the Gee
Posts: 308
Joined: Mon Feb 02, 2004 12:24 pm
Location: South Africa

Re: Not able to upload any pictures

Post by Beep » Thu Apr 11, 2024 7:14 am

Any update ?
42MB 130700

Scrumps
G-Lieutenant Colonel
G-Lieutenant Colonel
Posts: 1066
Joined: Thu Aug 17, 2017 11:39 am
Location: Somerset UK

Re: Not able to upload any pictures

Post by Scrumps » Sat Apr 13, 2024 12:19 pm

Hi,

When I recently tried to upload, it appeared to work but then threw me out with an error message about “unable to generate thumbnail”.

Haven’t tried since!

Scrumps
Dec '42 Willys MB
Aug ‘44 Willys MB
2021 New Defender 90 D250 HSE
2005 Landrover 90 CSW
2024 Range Rover Sport
1967 MGB
Royal Navy Weapons Engineer 1979-2007.

User avatar
thovis
G-Colonel
G-Colonel
Posts: 1209
Joined: Fri Oct 08, 2004 9:35 am
Location: Central Coast, CA
Contact:

Re: Not able to upload any pictures

Post by thovis » Mon Apr 15, 2024 6:39 pm

*Update* I think this is finally fixed. Let me explain.
Original problem:
1) Host applied an SSL cert requiring all links referring to http:// causes errors for files not loading.

Tom's original approach
1) Remove the SSL cert and return back to http:// references --> Styling worked

Local browsers did not like this because G503 and the .za sites referring to http:// gave cross browser https to http issues and images not rendering

Solution
1) Receive Ron's approval for updating surfacezero to the https (done)
2) Apply the https cert back to site (done)
3) make all changes of configs/data for http:// to https:// (done)
4) Verify upload still works (done)
5) make sure all styling on surfacezero works (done)

Should be good now everyone... let me know if any issues.

Tom H
Restore help
http://1942GPW.com - http://1945GPW.com
http://1941MB.com - http://1945MB.com
G506 Chevrolet Cargo
G506 Chevrolet Panel

Steve Webb
G-General
G-General
Posts: 16733
Joined: Fri Jan 17, 2003 3:40 pm
Location: Fort Myers, Florida

Re: Not able to upload any pictures

Post by Steve Webb » Tue Apr 16, 2024 3:25 am

I don't understand any of that but it is working so thank you.
Stand for the Flag, Kneel for the Cross Psalm 55; 9-11

User avatar
zepher11
G-Lieutenant General
G-Lieutenant General
Posts: 4387
Joined: Fri Aug 12, 2011 7:37 pm
Location: The Real Northern CalifornIA

Re: Not able to upload any pictures

Post by zepher11 » Tue Apr 16, 2024 3:56 am

Thank you Tom. All looks good now. I can see all the linked photos in the threads, and surfacezero works in Chrome now.

Appreciate all your work!
Zeph

'42 Script GPW Restoration Thread: CLICK HERE!

'41 Dodge WC16 Restoration Thread: CLICK HERE!

User avatar
Beep
Sergeant Major of the Gee
Sergeant Major of the Gee
Posts: 308
Joined: Mon Feb 02, 2004 12:24 pm
Location: South Africa

Re: Not able to upload any pictures

Post by Beep » Thu Apr 18, 2024 11:16 am

Many Many thanks Tom.
Everything seems to be working fine my side :D :D
42MB 130700


Post Reply

Return to “Surface Zero - G503 photo hosting”

Who is online

Users browsing this forum: No registered users and 2 guests