M151A2 Electrical system not connecting?

M151 General Discussion and Chat Board
Post Reply
oldranger63
G-Private
G-Private
Posts: 3
Joined: Sun Jul 08, 2018 6:17 pm
Location: Eugene, OR

M151A2 Electrical system not connecting?

Post by oldranger63 » Tue Feb 16, 2021 5:40 pm

I have a 1970 M151A2 that hasn't been run since last Oct. 2020. I've kept trickle chargers on both batteries, checked with multi-meter, both batteries are charged. After connecting battery cables, I switched the ignition switch on, but the voltage meter didn't move. Rechecked cables, nothing, replaced ignition switch and still dead. I've searched through the TM's and I'm unable to find a cause for any electrical problem. Has something similar happened or could someone let me know what else to check.


hambone
Sergeant Major of the Gee
Sergeant Major of the Gee
Posts: 265
Joined: Wed Oct 23, 2013 7:25 am
Location: El Dorado, Ar.

Re: M151A2 Electrical system not connecting?

Post by hambone » Tue Feb 16, 2021 6:16 pm

I would check for a bad ground, meter grounds through the hold down bracket, also check the ground on the gauge mounting plate, it's grounded to the dash by a ground wire.

Rickf
G-Lieutenant General
G-Lieutenant General
Posts: 5203
Joined: Sun Mar 19, 2006 12:04 pm
Location: Pemberton, New Jersey

Re: M151A2 Electrical system not connecting?

Post by Rickf » Wed Feb 17, 2021 7:42 pm

Is it just the gauge or do you have no power to anything? Do the headlights work? Does the starter crank the engine? The power comes from the #5 wire which attaches at the starter switch on the floor so if the grounds check out good you might want to check to see if that connection is bad. Be sure to check the ground wire from the batteries to the body, take it off, clean the connection on the body and the wire and put it back. If you are going to check the connections on the starter switch be sure to take the ground cable off the batteries before taking that switch out of the floor. A lot of bare metal exposed there as it comes out, once out you can put some cardboard on the floor and lay the switch on that and hook the batteries back up to test things. Once you are at that point you might as well take the wires and cables off and clean them since you are there. Do that while disconnected.
1964 M151A1
1984 M1008
1967 M416
04/1952 M100
12/1952 M100- Departed
AN/TSQ-114A Trailblazer- Gone

markrdje
USMC Sergeant
USMC Sergeant
Posts: 705
Joined: Sat Jun 13, 2009 1:44 pm
Location:

Re: M151A2 Electrical system not connecting?

Post by markrdje » Wed Feb 17, 2021 8:17 pm

I would check the gauge 1st to see if it works, which this is a repeat of what rickf said
change user name to mark


Post Reply

Return to “M151 General Discussion Board”

Who is online

Users browsing this forum: No registered users and 1 guest